You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

54 lines
1.3KB

  1. buildscript {
  2. dependencies {
  3. classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.40"
  4. }
  5. }
  6. plugins {
  7. id 'fabric-loom' version '0.2.2-SNAPSHOT'
  8. }
  9. apply plugin: 'kotlin'
  10. configurations.runtimeOnly.extendsFrom(configurations.modCompile)
  11. repositories {
  12. maven { url = "https://maven.abusedmaster.xyz/" }
  13. maven { url = "https://jitpack.io" }
  14. }
  15. dependencies {
  16. minecraft "com.mojang:minecraft:1.14.4"
  17. mappings "net.fabricmc:yarn:1.14.4+build.8"
  18. modCompile "net.fabricmc:fabric-loader:0.4.8+build.159"
  19. modCompile "net.fabricmc.fabric-api:fabric-api:0.3.0+build.207"
  20. modCompile (group: "net.fabricmc", name: "fabric-language-kotlin", version: "1.3.40+build.1")
  21. modCompile "com.github.NerdHubMC.Cardinal-Components-API:cardinal-components-base:2.0.1-SNAPSHOT"
  22. modCompile "com.github.NerdHubMC.Cardinal-Components-API:cardinal-components-block:2.0.1-SNAPSHOT"
  23. modCompile "com.github.NerdHubMC:Cardinal-Energy:1.3.0"
  24. }
  25. version = "0.1.1"
  26. archivesBaseName = "JAPTA2-mc1.14-fabric"
  27. processResources {
  28. inputs.property "version", project.version
  29. from(sourceSets.main.resources.srcDirs) {
  30. include "fabric.mod.json"
  31. expand "version": project.version
  32. }
  33. from(sourceSets.main.resources.srcDirs) {
  34. exclude "fabric.mod.json"
  35. }
  36. }
  37. java {
  38. sourceCompatibility = JavaVersion.VERSION_1_8
  39. targetCompatibility = JavaVersion.VERSION_1_8
  40. }